ramips: add support for YunCore G720
[openwrt/staging/stintel.git] / target / linux / ramips / image / mt7621.mk
index a46ea39d59ff5af5cb0e11289917439129681204..3b9ee022f61a1d0bf42c894d693f2fb13d5617a8 100644 (file)
@@ -2918,6 +2918,16 @@ define Device/yuncore_fap690
 endef
 TARGET_DEVICES += yuncore_fap690
 
+define Device/yuncore_g720
+  $(Device/dsa-migration)
+  DEVICE_VENDOR := YunCore
+  DEVICE_MODEL := G720
+  DEVICE_PACKAGES := kmod-mt7915-firmware
+  IMAGE_SIZE := 15808k
+  SUPPORTED_DEVICES += mt7621-rfb-ax-nor
+endef
+TARGET_DEVICES += yuncore_g720
+
 define Device/zbtlink_zbt-we1326
   $(Device/dsa-migration)
   $(Device/uimage-lzma-loader)