ramips: add support for ASUS RT-N56U B1
[openwrt/staging/ynezz.git] / target / linux / ramips / image / mt7621.mk
index ce9a3ae3d23f4004c64b13d55f1fad919bc82154..7b8a73c1bd7b09c7dd0bfc277371a5e613fca6db 100644 (file)
@@ -188,6 +188,17 @@ define Device/asus_rt-ac85p
 endef
 TARGET_DEVICES += asus_rt-ac85p
 
+define Device/asus_rt-n56u-b1
+  $(Device/dsa-migration)
+  DEVICE_VENDOR := ASUS
+  DEVICE_MODEL := RT-N56U
+  DEVICE_VARIANT := B1
+  IMAGE_SIZE := 16064k
+  DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 \
+       kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += asus_rt-n56u-b1
+
 define Device/buffalo_wsr-1166dhp
   $(Device/dsa-migration)
   $(Device/uimage-lzma-loader)