ramips: add support for Netgear R6350
[openwrt/openwrt.git] / target / linux / ramips / image / mt7621.mk
index 6a04cd0e3804bdbd1a15f0c364ca2bac59eebbcb..d4c9a100ed0b791f85a23e1b11f606f828334813 100644 (file)
@@ -297,6 +297,23 @@ define Device/r6220
 endef
 TARGET_DEVICES += r6220
 
+define Device/netgear_r6350
+  DTS := R6350
+  BLOCKSIZE := 128k
+  PAGESIZE := 2048
+  KERNEL_SIZE := 4096k
+  IMAGE_SIZE := 40960k
+  UBINIZE_OPTS := -E 5
+  IMAGES += kernel.bin rootfs.bin
+  IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
+  IMAGE/kernel.bin := append-kernel
+  IMAGE/rootfs.bin := append-ubi | check-size $$$$(IMAGE_SIZE)
+  DEVICE_TITLE := Netgear R6350
+  DEVICE_PACKAGES := \
+       kmod-mt7603 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
+endef
+TARGET_DEVICES += netgear_r6350
+
 define Device/rb750gr3
   DTS := RB750Gr3
   IMAGE_SIZE := $(ralink_default_fw_size_16M)
@@ -558,12 +575,3 @@ define Device/zbt-wg3526-32M
        kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
 endef
 TARGET_DEVICES += zbt-wg3526-32M
-
-# FIXME: is this still needed?
-define Image/Prepare
-#define Build/Compile
-       rm -rf $(KDIR)/relocate
-       $(CP) ../../generic/image/relocate $(KDIR)
-       $(MAKE) -C $(KDIR)/relocate KERNEL_ADDR=$(KERNEL_LOADADDR) CROSS_COMPILE=$(TARGET_CROSS)
-       $(CP) $(KDIR)/relocate/loader.bin $(KDIR)/loader.bin
-endef