ramips: add preliminary support for SGE AP-MTKH7-0006 developer board
[openwrt/openwrt.git] / target / linux / ramips / image / mt7621.mk
index 7f9491104a67325e7749b765680ff3be4eea4850..eeda908c444bac81522855e21136b61c7198164b 100644 (file)
@@ -275,7 +275,7 @@ TARGET_DEVICES += iodata_wn-ax1167gr
 
 define Device/iodata_wn-gx300gr
   MTK_SOC := mt7621
-  IMAGE_SIZE := 7798784
+  IMAGE_SIZE := 7616k
   DEVICE_VENDOR := I-O DATA
   DEVICE_MODEL := WN-GX300GR
   DEVICE_PACKAGES := kmod-mt7603 wpad-basic
@@ -669,7 +669,8 @@ define Device/xiaomi_mir3p
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
   IMAGE/factory.bin := append-kernel | pad-to $$(KERNEL_SIZE) | append-ubi | check-size $$$$(IMAGE_SIZE)
   DEVICE_PACKAGES := \
-       kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic uboot-envtools
+       kmod-mt7615e kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic \
+       uboot-envtools
 endef
 TARGET_DEVICES += xiaomi_mir3p
 
@@ -684,6 +685,17 @@ define Device/xzwifi_creativebox-v1
 endef
 TARGET_DEVICES += xzwifi_creativebox-v1
 
+define Device/ap-mtkh7-0006
+  DTS := AP-MTKH7-0006
+  IMAGE_SIZE := $(ralink_default_fw_size_32M)
+  SUPPORTED_DEVICES := sge,ap-mtkh7-0006
+  DEVICE_TITLE := SGE AP-MTKH7-0006
+  DEVICE_PACKAGES := \
+       kmod-sdhci-mt7620 kmod-mt7603 kmod-mt76x2 \
+       kmod-usb3 kmod-usb-ledtrig-usbport wpad-mini
+endef
+TARGET_DEVICES += ap-mtkh7-0006
+
 define Device/youhua_wr1200js
   MTK_SOC := mt7621
   IMAGE_SIZE := 16064k