ramips: add support for Wavlink WL-WN570HA1
[openwrt/openwrt.git] / target / linux / ramips / image / mt76x8.mk
index 6bedb4f7d420576227e4ea937765681fc77582f7..af5b0f6d608b0c37e4360ca7a4f5b4584ebbb66a 100644 (file)
@@ -150,6 +150,14 @@ define Device/pbr-d1
 endef
 TARGET_DEVICES += pbr-d1
 
+define Device/skylab_skw92a
+  DTS := SKW92A
+  IMAGE_SIZE := 16064k
+  DEVICE_TITLE := Skylab SKW92A
+  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+endef
+TARGET_DEVICES += skylab_skw92a
+
 define Device/tplink_tl-wa801nd-v5
   $(Device/tplink)
   DTS := TL-WA801NDV5
@@ -313,6 +321,14 @@ define Device/vocore2lite
 endef
 TARGET_DEVICES += vocore2lite
 
+define Device/wavlink_wl-wn570ha1
+  DTS := WL-WN570HA1
+  IMAGE_SIZE := $(ralink_default_fw_size_8M)
+  DEVICE_TITLE := Wavlink WL-WN570HA1
+  DEVICE_PACKAGES := kmod-mt76x0e
+endef
+TARGET_DEVICES += wavlink_wl-wn570ha1
+
 define Device/wcr-1166ds
   DTS := WCR-1166DS
   BUFFALO_TAG_PLATFORM := MTK