ramips: fix R6120 factory image
[openwrt/staging/chunkeey.git] / target / linux / ramips / image / mt76x8.mk
index 571ddf3d51bc9c0ebba66bd9c7074f42e5e4da17..ba3354a8a68b7fa6e75793a5113673bff0571eeb 100644 (file)
@@ -135,7 +135,7 @@ define Device/netgear_r6120
   IMAGES += factory.img
   IMAGE/default := append-kernel | pad-to $$$$(BLOCKSIZE)| append-rootfs | pad-rootfs
   IMAGE/sysupgrade.bin := $$(IMAGE/default) | append-metadata | check-size $$$$(IMAGE_SIZE)
-  IMAGE/factory.img := pad-extra 576k | $$(IMAGE/default) | \
+  IMAGE/factory.img := pad-extra 576k | $$(IMAGE/default) | pad-to $$$$(BLOCKSIZE) | \
        sercom-footer | pad-to 128 | zip R6120.bin | sercom-seal
 endef
 TARGET_DEVICES += netgear_r6120