treewide: omit IMAGE_SIZE argument from check-size
[openwrt/staging/ldir.git] / target / linux / ramips / image / rt288x.mk
index 460df28538762b39e7d37075cfdbe6a1449ba39c..720ff657419d46c8d219ed0581b59dc6e7e375f8 100644 (file)
@@ -2,6 +2,8 @@
 # RT288X Profiles
 #
 
+DEFAULT_SOC := rt2880
+
 define Build/gemtek-header
        if [ -f $@ ]; then \
                mkheader_gemtek $@ $@.new $(1) && \
@@ -10,21 +12,19 @@ define Build/gemtek-header
 endef
 
 define Device/airlink101_ar670w
-  MTK_SOC := rt2880
   BLOCKSIZE := 64k
   DEVICE_VENDOR := Airlink
   DEVICE_MODEL := AR670W
   IMAGE_SIZE := 3840k
   KERNEL := $(KERNEL_DTB) | pad-to $$(BLOCKSIZE)
   IMAGES += factory.bin
-  IMAGE/factory.bin := $$(sysupgrade_bin) | check-size $$$$(IMAGE_SIZE) | \
+  IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | \
        wrg-header wrgn16a_airlink_ar670w
   SUPPORTED_DEVICES += ar670w
 endef
 TARGET_DEVICES += airlink101_ar670w
 
 define Device/airlink101_ar725w
-  MTK_SOC := rt2880
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Airlink
   DEVICE_MODEL := AR725W
@@ -36,7 +36,6 @@ endef
 TARGET_DEVICES += airlink101_ar725w
 
 define Device/asus_rt-n15
-  MTK_SOC := rt2880
   BLOCKSIZE := 64k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Asus
@@ -47,19 +46,17 @@ endef
 TARGET_DEVICES += asus_rt-n15
 
 define Device/belkin_f5d8235-v1
-  MTK_SOC := rt2880
   IMAGE_SIZE := 7872k
   DEVICE_VENDOR := Belkin
   DEVICE_MODEL := F5D8235
   DEVICE_VARIANT := V1
   DEVICE_PACKAGES := kmod-switch-rtl8366s kmod-usb-ohci \
-    kmod-usb-ohci-pci kmod-usb2 kmod-usb2-pci kmod-usb-ledtrig-usbport
+       kmod-usb-ohci-pci kmod-usb2 kmod-usb2-pci kmod-usb-ledtrig-usbport
   SUPPORTED_DEVICES += f5d8235-v1
 endef
 TARGET_DEVICES += belkin_f5d8235-v1
 
 define Device/buffalo_wli-tx4-ag300n
-  MTK_SOC := rt2880
   BLOCKSIZE := 64k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Buffalo
@@ -70,7 +67,6 @@ endef
 TARGET_DEVICES += buffalo_wli-tx4-ag300n
 
 define Device/buffalo_wzr-agl300nh
-  MTK_SOC := rt2880
   BLOCKSIZE := 64k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Buffalo
@@ -81,7 +77,6 @@ endef
 TARGET_DEVICES += buffalo_wzr-agl300nh
 
 define Device/dlink_dap-1522-a1
-  MTK_SOC := rt2880
   BLOCKSIZE := 64k
   IMAGE_SIZE := 3712k
   DEVICE_VENDOR := D-Link
@@ -90,16 +85,13 @@ define Device/dlink_dap-1522-a1
   DEVICE_PACKAGES := kmod-switch-rtl8366s
   KERNEL := $(KERNEL_DTB)
   IMAGES += factory.bin
-  IMAGE/factory.bin := \
-       append-kernel | pad-offset $$$$(BLOCKSIZE) 96 | \
-       append-rootfs | pad-rootfs -x 96 | \
-       wrg-header wapnd01_dlink_dap1522 | \
-       check-size $$$$(IMAGE_SIZE)
+  IMAGE/factory.bin := append-kernel | pad-offset $$$$(BLOCKSIZE) 96 | \
+       append-rootfs | pad-rootfs -x 96 | wrg-header wapnd01_dlink_dap1522 | \
+       check-size
 endef
 TARGET_DEVICES += dlink_dap-1522-a1
 
 define Device/ralink_v11st-fe
-  MTK_SOC := rt2880
   BLOCKSIZE := 64k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Ralink