ramips: set blocksize for 4MB devices
[openwrt/staging/mkresin.git] / target / linux / ramips / image / rt288x.mk
index ebb523e461af67937d66d266a6a9e9ac7ffac4d3..7e7652e9ec12cb36062c7020ff2dc2e86f9b497b 100644 (file)
@@ -15,6 +15,7 @@ endef
 
 define Device/ar670w
   DTS := AR670W
+  BLOCKSIZE := 64k
   DEVICE_TITLE := Airlink AR670W
   IMAGE_SIZE := $(ralink_default_fw_size_4M)
   KERNEL := $(KERNEL_DTB)
@@ -41,6 +42,7 @@ TARGET_DEVICES += f5d8235v1
 
 define Device/rt-n15
   DTS := RT-N15
+  BLOCKSIZE := 64k
   IMAGE_SIZE := $(ralink_default_fw_size_4M)
   DEVICE_TITLE := Asus RT-N15
   DEVICE_PACKAGES := kmod-switch-rtl8366s
@@ -49,6 +51,7 @@ TARGET_DEVICES += rt-n15
 
 define Device/v11st-fe
   DTS := V11STFE
+  BLOCKSIZE := 64k
   IMAGE_SIZE := $(ralink_default_fw_size_4M)
   DEVICE_TITLE := Ralink V11ST-FE
 endef
@@ -56,6 +59,7 @@ TARGET_DEVICES += v11st-fe
 
 define Device/wli-tx4-ag300n
   DTS := WLI-TX4-AG300N
+  BLOCKSIZE := 64k
   IMAGE_SIZE := $(ralink_default_fw_size_4M)
   DEVICE_TITLE := Buffalo WLI-TX4-AG300N
 endef
@@ -63,6 +67,7 @@ TARGET_DEVICES += wli-tx4-ag300n
 
 define Device/wzr-agl300nh
   DTS := WZR-AGL300NH
+  BLOCKSIZE := 64k
   IMAGE_SIZE := $(ralink_default_fw_size_4M)
   DEVICE_TITLE := Buffalo WZR-AGL300NH
   DEVICE_PACKAGES := kmod-switch-rtl8366s