treewide: Disable building 32M RAM devices
[openwrt/openwrt.git] / target / linux / ramips / image / rt3883.mk
index 1b46d570fd945dffa41b1455c7b31c2bc0377e86..04300992965c73fd7e37cef591282057180072cf 100644 (file)
@@ -7,10 +7,9 @@ endef
 
 define Device/asus_rt-n56u
   SOC := rt3662
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 7872k
   IMAGE/sysupgrade.bin += | mkrtn56uimg -s
-  DEVICE_VENDOR := Asus
+  DEVICE_VENDOR := ASUS
   DEVICE_MODEL := RT-N56U
   DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2
   SUPPORTED_DEVICES += rt-n56u
@@ -18,26 +17,22 @@ endef
 TARGET_DEVICES += asus_rt-n56u
 
 define Device/belkin_f9k1109v1
+  $(Device/uimage-lzma-loader)
   SOC := rt3883
-  BLOCKSIZE := 64k
   DEVICE_VENDOR := Belkin
   DEVICE_MODEL := F9K1109
   DEVICE_VARIANT := Version 1.0
   DEVICE_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
   IMAGE_SIZE := 7808k
-  KERNEL := kernel-bin | append-dtb | lzma -d16 | uImage lzma
   # Stock firmware checks for this uImage image name during upload.
   UIMAGE_NAME := N750F9K1103VB
 endef
 TARGET_DEVICES += belkin_f9k1109v1
 
 define Device/dlink_dir-645
-  $(Device/seama)
-  $(Device/uimage-lzma-loader)
+  $(Device/seama-lzma-loader)
   SOC := rt3662
-  BLOCKSIZE := 4k
   IMAGE_SIZE := 7872k
-  KERNEL := kernel-bin | append-dtb | lzma -d10
   SEAMA_SIGNATURE := wrgn39_dlob.hans_dir645
   DEVICE_VENDOR := D-Link
   DEVICE_MODEL := DIR-645
@@ -48,11 +43,10 @@ TARGET_DEVICES += dlink_dir-645
 
 define Device/edimax_br-6475nd
   SOC := rt3662
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 7744k
   IMAGE/sysupgrade.bin := append-kernel | append-rootfs | \
        edimax-header -s CSYS -m RN54 -f 0x70000 -S 0x01100000 | pad-rootfs | \
-       append-metadata | check-size
+       check-size | append-metadata
   DEVICE_VENDOR := Edimax
   DEVICE_MODEL := BR-6475nD
   SUPPORTED_DEVICES += br-6475nd
@@ -62,7 +56,6 @@ TARGET_DEVICES += edimax_br-6475nd
 define Device/engenius_esr600h
   $(Device/uimage-lzma-loader)
   SOC := rt3662
-  BLOCKSIZE := 4k
   IMAGE_SIZE := 7872k
   IMAGES += factory.dlf
   IMAGE/factory.dlf := $$(sysupgrade_bin) | check-size | \
@@ -75,17 +68,16 @@ TARGET_DEVICES += engenius_esr600h
 
 define Device/loewe_wmdr-143n
   SOC := rt3662
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 7872k
   DEVICE_VENDOR := Loewe
   DEVICE_MODEL := WMDR-143N
   SUPPORTED_DEVICES += wmdr-143n
+  DEFAULT := n
 endef
 TARGET_DEVICES += loewe_wmdr-143n
 
 define Device/omnima_hpm
   SOC := rt3662
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 16064k
   DEVICE_VENDOR := Omnima
   DEVICE_MODEL := HPM
@@ -97,7 +89,6 @@ TARGET_DEVICES += omnima_hpm
 define Device/samsung_cy-swr1100
   $(Device/seama)
   SOC := rt3662
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 7872k
   KERNEL := $(KERNEL_DTB)
   SEAMA_SIGNATURE := wrgnd10_samsung_ss815
@@ -109,8 +100,8 @@ endef
 TARGET_DEVICES += samsung_cy-swr1100
 
 define Device/sitecom_wlr-6000
+  $(Device/uimage-lzma-loader)
   SOC := rt3883
-  BLOCKSIZE := 4k
   IMAGE_SIZE := 7244k
   IMAGES += factory.dlf
   IMAGE/factory.dlf := $$(sysupgrade_bin) | check-size | \
@@ -124,7 +115,6 @@ TARGET_DEVICES += sitecom_wlr-6000
 
 define Device/trendnet_tew-691gr
   SOC := rt3883
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 7872k
   IMAGES += factory.bin
   IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | umedia-header 0x026910
@@ -136,7 +126,6 @@ TARGET_DEVICES += trendnet_tew-691gr
 
 define Device/trendnet_tew-692gr
   SOC := rt3883
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 7872k
   IMAGES += factory.bin
   IMAGE/factory.bin := $$(sysupgrade_bin) | check-size | umedia-header 0x026920