kernel: make kmod-i2c-core selected by dependent modules
[openwrt/staging/wigyori.git] / target / linux / ramips / modules.mk
index 89bdc6c95c33f0112664cb8a3e74138be8375a18..1ce914439cbbb1312d822e6f159aa2446cb4cc4a 100644 (file)
@@ -47,7 +47,7 @@ I2C_RALINK_MODULES:= \
 define KernelPackage/i2c-ralink
   $(call i2c_defaults,$(I2C_RALINK_MODULES),59)
   TITLE:=Ralink I2C Controller
-  DEPENDS:=kmod-i2c-core @TARGET_ramips \
+  DEPENDS:=+kmod-i2c-core @TARGET_ramips \
        @!(TARGET_ramips_mt7621||TARGET_ramips_mt76x8)
 endef
 
@@ -64,7 +64,7 @@ I2C_MT7621_MODULES:= \
 define KernelPackage/i2c-mt7628
   $(call i2c_defaults,$(I2C_MT7621_MODULES),59)
   TITLE:=MT7628/88 I2C Controller
-  DEPENDS:=kmod-i2c-core \
+  DEPENDS:=+kmod-i2c-core \
        @(TARGET_ramips_mt76x8)
 endef