realtek: update the tree to the latest refactored version
[openwrt/openwrt.git] / target / linux / realtek / Makefile
diff --git a/target/linux/realtek/Makefile b/target/linux/realtek/Makefile
new file mode 100644 (file)
index 0000000..98fcaf3
--- /dev/null
@@ -0,0 +1,27 @@
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mips
+CPU_TYPE:=4kec
+BOARD:=realtek
+BOARDNAME:=Realtek MIPS
+DEVICE_TYPE:=basic
+FEATURES:=ramdisk squashfs
+SUBTARGETS:=generic
+
+KERNEL_PATCHVER:=5.4
+
+define Target/Description
+       Build firmware images for Realtek RTL83xx based boards.
+endef
+
+include $(INCLUDE_DIR)/target.mk
+
+FEATURES := $(filter-out mips16,$(FEATURES))
+
+DEFAULT_PACKAGES += uboot-envtools ethtool kmod-gpio-button-hotplug \
+       dnsmasq firewall ip6tables iptables odhcp6c odhcpd-ipv6only
+
+$(eval $(call BuildTarget))