realtek: add common definition of cameo based firmware
[openwrt/staging/stintel.git] / target / linux / realtek / image / common.mk
index 1a1d6356a767e0d2be411d41697912ae2bbd7479..37370f1999839ffb0487746bac06410e53aeb447 100644 (file)
@@ -1,19 +1,13 @@
 # SPDX-License-Identifier: GPL-2.0-only
 
-define Device/d-link_dgs-1210
-  IMAGE_SIZE := 13824k
-  DEVICE_VENDOR := D-Link
-  DLINK_KERNEL_PART_SIZE := 1572864
+define Device/cameo-fw
+  CAMEO_BOARD_MODEL = $$(DEVICE_MODEL)
   KERNEL := \
        kernel-bin | \
        append-dtb | \
        libdeflate-gzip | \
        uImage gzip | \
        cameo-tag
-  CAMEO_KERNEL_PART := 2
-  CAMEO_ROOTFS_PART := 3
-  CAMEO_CUSTOMER_SIGNATURE := 2
-  CAMEO_BOARD_VERSION := 32
   IMAGES += factory_image1.bin
   IMAGE/factory_image1.bin := \
        append-kernel | \
@@ -26,6 +20,17 @@ define Device/d-link_dgs-1210
        cameo-headers
 endef
 
+define Device/d-link_dgs-1210
+  $(Device/cameo-fw)
+  IMAGE_SIZE := 13824k
+  DEVICE_VENDOR := D-Link
+  CAMEO_KERNEL_PART_SIZE := 1572864
+  CAMEO_KERNEL_PART := 2
+  CAMEO_ROOTFS_PART := 3
+  CAMEO_CUSTOMER_SIGNATURE := 2
+  CAMEO_BOARD_VERSION := 32
+endef
+
 define Device/hpe_1920
   DEVICE_VENDOR := HPE
   IMAGE_SIZE := 29632k