realtek/rtl839x: Edgecore ECS4100-12PH support
[openwrt/staging/stintel.git] / target / linux / realtek / image / rtl839x.mk
index 65078e0c4442ebebe4841066a44158d4fdcea2a8..90a58180fd5372421d830b20c0c35e79a2470ea9 100644 (file)
@@ -9,6 +9,14 @@ define Device/d-link_dgs-1210-52
 endef
 TARGET_DEVICES += d-link_dgs-1210-52
 
+define Device/edgecore_ecs4100-12ph
+  SOC := rtl8392
+  DEVICE_VENDOR := Edgecore
+  DEVICE_MODEL := ECS4100-12PH
+  IMAGE_SIZE := 14336k
+endef
+TARGET_DEVICES += edgecore_ecs4100-12ph
+
 # When the factory image won't fit anymore, it can be removed.
 # New installation will be performed booting the initramfs image from
 # ram and then flashing the sysupgrade image from OpenWrt