rockchip: add Orange Pi R1 Plus LTS support
[openwrt/staging/jow.git] / target / linux / rockchip / image / armv8.mk
index 9a32a07b21aff033b5d0a527a4f94088fb4cb986..063dc6fd644795f45969ae72a9c44b761999d633 100644 (file)
@@ -69,3 +69,12 @@ define Device/xunlong_orangepi-r1-plus
   DEVICE_PACKAGES := kmod-usb-net-rtl8152
 endef
 TARGET_DEVICES += xunlong_orangepi-r1-plus
+
+define Device/xunlong_orangepi-r1-plus-lts
+  DEVICE_VENDOR := Xunlong
+  DEVICE_MODEL := Orange Pi R1 Plus LTS
+  SOC := rk3328
+  IMAGE/sysupgrade.img.gz := boot-common | boot-script | pine64-img | gzip | append-metadata
+  DEVICE_PACKAGES := kmod-usb-net-rtl8152
+endef
+TARGET_DEVICES += xunlong_orangepi-r1-plus-lts