treewide: gather DEVICE_VARS into one place
[openwrt/openwrt.git] / target / linux / sunxi / image / Makefile
index cb8febca413f028e87d56d0e567a2d1149824b46..1b98849a5048dd1353864b86d51bf29e77a1d0a3 100644 (file)
@@ -11,6 +11,7 @@ include $(INCLUDE_DIR)/image.mk
 FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_SUNXI_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
+DEVICE_VARS := SUNXI_DTS SUNXI_DTS_DIR
 KERNEL_LOADADDR:=0x40008000
 
 define Build/sunxi-sdcard
@@ -32,7 +33,6 @@ endef
 # why \x00\x00\x00\x00 for zImage-initramfs
 define Device/Default
   PROFILES := Default
-  DEVICE_VARS := SUNXI_DTS SUNXI_DTS_DIR
   KERNEL_NAME := zImage
   KERNEL := kernel-bin | uImage none
   IMAGES := sdcard.img.gz