sunxi: fix sunxi-ir kconfig and description
[openwrt/openwrt.git] / target / linux / sunxi / modules.mk
index 0c8ed83d0d8972c0dac60932d3a15030a7a8d5aa..8bbafe98a7b13be352de302e646d4d009d1c55b5 100644 (file)
@@ -21,19 +21,20 @@ $(eval $(call KernelPackage,rtc-sunxi))
 
 define KernelPackage/sunxi-ir
     SUBMENU:=$(OTHER_MENU)
-    TITLE:=Sunxi SoC built-in IR support (A20)
+    TITLE:=Sunxi SoC built-in IR support
     DEPENDS:=@(TARGET_sunxi&&RTC_SUPPORT) +kmod-input-core
     KCONFIG:= \
        CONFIG_MEDIA_SUPPORT=y \
        CONFIG_MEDIA_RC_SUPPORT=y \
        CONFIG_RC_DEVICES=y \
+       CONFIG_RC_CORE=y \
        CONFIG_IR_SUNXI
     FILES:=$(LINUX_DIR)/drivers/media/rc/sunxi-cir.ko
     AUTOLOAD:=$(call AutoLoad,50,sunxi-cir)
 endef
 
 define KernelPackage/sunxi-ir/description
- Support for the AllWinner sunXi SoC's onboard IR (A20)
+ Support for the AllWinner sunXi SoC's onboard IR
 endef
 
 $(eval $(call KernelPackage,sunxi-ir))