[ubicom32]: move new files out from platform support patch
[openwrt/svn-archive/archive.git] / target / linux / ubicom32 / files / arch / ubicom32 / mach-ip7k / Makefile
diff --git a/target/linux/ubicom32/files/arch/ubicom32/mach-ip7k/Makefile b/target/linux/ubicom32/files/arch/ubicom32/mach-ip7k/Makefile
new file mode 100644 (file)
index 0000000..f9df397
--- /dev/null
@@ -0,0 +1,38 @@
+#
+# arch/ubicom32/mach-ip7k/Makefile
+#      Makefile for ip7k based boards.
+#
+# (C) Copyright 2009, Ubicom, Inc.
+#
+# This file is part of the Ubicom32 Linux Kernel Port.
+#
+# The Ubicom32 Linux Kernel Port is free software: you can redistribute
+# it and/or modify it under the terms of the GNU General Public License
+# as published by the Free Software Foundation, either version 2 of the
+# License, or (at your option) any later version.
+#
+# The Ubicom32 Linux Kernel Port is distributed in the hope that it
+# will be useful, but WITHOUT ANY WARRANTY; without even the implied
+# warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See
+# the GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with the Ubicom32 Linux Kernel Port.  If not,
+# see <http://www.gnu.org/licenses/>.
+#
+# Ubicom32 implementation derived from (with many thanks):
+#   arch/m68knommu
+#   arch/blackfin
+#   arch/parisc
+#
+
+obj-$(CONFIG_IP7145DPF)                += board-ip7145dpf.o
+obj-$(CONFIG_IP7160RGW)                += board-ip7160rgw.o
+obj-$(CONFIG_IP7160RGWLCD)     += board-ip7160rgw.o
+obj-$(CONFIG_IP7160BRINGUP)    += board-ip7160bringup.o
+obj-$(CONFIG_IP7160DPF)                += board-ip7160dpf.o
+obj-$(CONFIG_IP7500MODULE)     += board-ip7500module.o
+obj-$(CONFIG_IP7500MEDIA)      += board-ip7500media.o
+obj-$(CONFIG_IP7500AV)         += board-ip7500av.o
+obj-$(CONFIG_IP7500WSPKR)      += board-ip7500wspkr.o
+obj-$(CONFIG_IP7500IAP)                += board-ip7500iap.o