uml: drop 32Bit host build support
[openwrt/staging/mkresin.git] / target / linux / uml / Makefile
index ae8ea5d309152de823624685d5cd82c9d4cc84e5..7c27dda0363734018dfdedc60dc8a080c37526b5 100644 (file)
@@ -1,20 +1,14 @@
 # SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2021 OpenWrt.org
 
 include $(TOPDIR)/rules.mk
 
 # UML only makes sense on linux
 ifeq ($(HOST_OS),Linux)
+  ifeq ($(HOST_ARCH),x86_64)
 
-ARCH:=$(shell uname -m | sed \
-       -e 's/i[3-9]86/i386/' \
-       -e 's/mipsel/mips/' \
-       -e 's/mipseb/mips/' \
-       -e 's/powerpc/ppc/' \
-       -e 's/sh[234]/sh/' \
-       -e 's/armeb/arm/' \
-)
+ARCH:=x86_64
 BOARD:=uml
 BOARDNAME:=User Mode Linux
 FEATURES:=squashfs ext4 audio source-only
@@ -23,10 +17,9 @@ KERNEL_PATCHVER:=5.4
 
 include $(INCLUDE_DIR)/target.mk
 
-LINUX_TARGET_CONFIG:=$(CURDIR)/config/$(ARCH)
-
 DEFAULT_PACKAGES += wpad-basic-wolfssl kmod-mac80211-hwsim mkf2fs e2fsprogs
 
+  endif
 endif
 
 $(eval $(call BuildTarget))