kernel: update to 3.10.49 Signed-off-by: John Crispin <blogic@openwrt.org>
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index 27987a41bf614dc3503afa79f7bd8f318ba0761f..32eafdfc0a50afacf760b63aa939c24f532536b0 100644 (file)
@@ -1,22 +1,26 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2
+FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
+SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos alix2 thincan \
+          rdc
+
+LINUX_VERSION:=3.10.49
 
-LINUX_VERSION:=2.6.22.4
+KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
-$(eval $(call Target,generic))
-$(eval $(call Target,mediacenter))
 $(eval $(call BuildTarget))
 
+$(eval $(call $(if $(CONFIG_TARGET_ROOTFS_ISO),RequireCommand,Ignore),mkisofs, \
+       Please install mkisofs. \
+))