kernel: update to 3.10.49 Signed-off-by: John Crispin <blogic@openwrt.org>
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index dd4eed4524844cc896b0473c0304c015fdf48ebe..32eafdfc0a50afacf760b63aa939c24f532536b0 100644 (file)
@@ -1,21 +1,23 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
 
-ARCH=i386
+ARCH:=i386
 BOARD:=x86
 BOARDNAME:=x86
-FEATURES:=squashfs jffs2 ext2
-SUBTARGETS=generic mediacenter
+FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
+SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos alix2 thincan \
+          rdc
+
+LINUX_VERSION:=3.10.49
 
-LINUX_VERSION:=2.6.23.9
+KERNELNAME:=bzImage
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci
 
 $(eval $(call BuildTarget))