target: use SPDX license identifiers on Makefiles
[openwrt/staging/chunkeey.git] / target / linux / x86 / modules.mk
index 0b03a398d986a4e70a427d612663911e2873abb1..24a4384577e398a3839c7b83ce86e65bc6537e00 100644 (file)
@@ -1,73 +1,51 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2006-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2017 Cezary Jackiewicz <cezary@eko.one.pll>
 
-define KernelPackage/cs5535
-  SUBMENU:=$(BLOCK_MENU)
-  TITLE:=NSC/AMD CS5535 chipset support
-  DEPENDS:=@TARGET_x86
-  KCONFIG:=CONFIG_BLK_DEV_CS5535
-  FILES=$(LINUX_DIR)/drivers/ide/cs5535.ko
-  AUTOLOAD:=$(call AutoLoad,30,cs5535,1)
-  $(call AddDepends/ide)
+define KernelPackage/sound-cs5535audio
+  TITLE:=CS5535/CS5536 Audio Controller
+  DEPENDS:=@TARGET_x86_geode +kmod-ac97
+  KCONFIG:=CONFIG_SND_CS5535AUDIO
+  FILES:=$(LINUX_DIR)/sound/pci/cs5535audio/snd-cs5535audio.ko
+  AUTOLOAD:=$(call AutoLoad,36,snd-cs5535audio)
+  $(call AddDepends/sound)
 endef
 
-define KernelPackage/cs5535/description
-  Kernel module for the NSC/AMD CS5535 companion chip
+define KernelPackage/sound-cs5535audio/description
+ Support for the integrated AC97 sound device on motherboards
+ with AMD CS5535/CS5536 chipsets.
 endef
 
-$(eval $(call KernelPackage,cs5535))
+$(eval $(call KernelPackage,sound-cs5535audio))
 
-
-define KernelPackage/cs5536
-  SUBMENU:=$(BLOCK_MENU)
-  TITLE:=AMD CS5536 chipset support
+define KernelPackage/sp5100-tco
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=SP5100 Watchdog Support
   DEPENDS:=@TARGET_x86
-  KCONFIG:=CONFIG_BLK_DEV_CS5536
-  FILES=$(LINUX_DIR)/drivers/ide/cs5536.ko
-  AUTOLOAD:=$(call AutoLoad,30,cs5536,1)
-  $(call AddDepends/ide)
-endef
-
-define KernelPackage/cs5536/description
-  Kernel module for the AMD CS5536 Geode LX companion chip
-endef
-
-$(eval $(call KernelPackage,cs5536))
-
-
-define KernelPackage/pata-cs5535
-  SUBMENU:=$(BLOCK_MENU)
-  TITLE:=CS5535 PATA support
-  DEPENDS:=@TARGET_x86 @PCI_SUPPORT
-  KCONFIG:=CONFIG_PATA_CS5535
-  FILES=$(LINUX_DIR)/drivers/ata/pata_cs5535.ko
-  AUTOLOAD:=$(call AutoLoad,30,pata_cs5535,1)
-  $(call AddDepends/ata)
+  KCONFIG:=CONFIG_SP5100_TCO
+  FILES:=$(LINUX_DIR)/drivers/watchdog/sp5100_tco.ko
+  AUTOLOAD:=$(call AutoLoad,50,sp5100_tco,1)
 endef
 
-define KernelPackage/pata-cs5535/description
-  Kernel module for the NSC/AMD CS5535 companion chip
+define KernelPackage/sp5100-tco/description
+ Kernel module for the SP5100_TCO hardware watchdog.
 endef
 
-$(eval $(call KernelPackage,pata-cs5535))
+$(eval $(call KernelPackage,sp5100-tco))
 
 
-define KernelPackage/pata-cs5536
-  SUBMENU:=$(BLOCK_MENU)
-  TITLE:=CS5536 PATA support
-  DEPENDS:=@TARGET_x86 @PCI_SUPPORT
-  KCONFIG:=CONFIG_PATA_CS5536
-  FILES=$(LINUX_DIR)/drivers/ata/pata_cs5536.ko
-  AUTOLOAD:=$(call AutoLoad,30,pata_cs5536,1)
-  $(call AddDepends/ata)
+define KernelPackage/pcengines-apuv2
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=PC Engines APUv2/3 front button and LEDs driver
+  DEPENDS:=@TARGET_x86 +kmod-gpio-amd-fch +kmod-leds-gpio
+  KCONFIG:=CONFIG_PCENGINES_APU2
+  FILES:=$(LINUX_DIR)/drivers/platform/x86/pcengines-apuv2.ko
+  AUTOLOAD:=$(call AutoLoad,60,pcengines-apuv2)
 endef
 
-define KernelPackage/pata-cs5536/description
-  Kernel module for the AMD CS5536 Geode LX companion chip
+define KernelPackage/pcengines-apuv2/description
+  This driver provides support for the front button and LEDs on
+  PC Engines APUv2/APUv3 board.
 endef
 
-$(eval $(call KernelPackage,pata-cs5536))
+$(eval $(call KernelPackage,pcengines-apuv2))