merge the RDC R-321x target as a subtarget of x86
[openwrt/openwrt.git] / target / linux / x86 / rdc / target.mk
diff --git a/target/linux/x86/rdc/target.mk b/target/linux/x86/rdc/target.mk
new file mode 100644 (file)
index 0000000..32b3004
--- /dev/null
@@ -0,0 +1,14 @@
+BOARDNAME:=RDC R-321x
+FEATURES:=squashfs jffs2 pci usb gpio pcmcia
+CFLAGS:=-Os -pipe -march=i486 -mtune=i486 -fno-caller-saves
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+
+DEFAULT_PACKAGES += kmod-llc kmod-stp kmod-bridge kmod-8021q \
+                   wpad-mini kmod-libphy kmod-r6040 kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug \
+                   kmod-rdc321x-wdt
+
+define Target/Description
+        Build firmware images for RDC321x based routers
+        (e.g. Airlink101 AR525W, Linksys WRT54GR, Sitecom WL-153)
+endef