target/linux/*/image/Makefile: eliminate more LINUX_DIR users
[openwrt/staging/mkresin.git] / target / linux / xburst / image / Makefile
index 0de5560c961e0ee3f96486b6f2ab468d3d8943ec..49bb254164ced11d4e31476bec0023d3096984dd 100644 (file)
@@ -27,7 +27,7 @@ endef
 define MkImageGzip
        gzip -9 -c $(1) > $(1).gz
        mkimage -A mips -O linux -T kernel -a 0x80010000 -C gzip \
-               -e $(call kernel_entry,$(LINUX_DIR)/vmlinux) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+               -e $(call kernel_entry,$(KDIR)/vmlinux.debug) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
                -d $(1).gz $(2)
 endef