[xburst] Seperate charger logic from battery driver
[openwrt/svn-archive/archive.git] / target / linux / xburst / patches-2.6.32 / 106-gpio-charger.patch
diff --git a/target/linux/xburst/patches-2.6.32/106-gpio-charger.patch b/target/linux/xburst/patches-2.6.32/106-gpio-charger.patch
new file mode 100644 (file)
index 0000000..dd1713a
--- /dev/null
@@ -0,0 +1,21 @@
+--- a/drivers/power/Makefile   2010-02-03 13:16:32.000000000 +0100
++++ b/drivers/power/Makefile   2010-02-01 14:55:46.000000000 +0100
+@@ -30,3 +30,4 @@
+ obj-$(CONFIG_BATTERY_MAX17040)        += max17040_battery.o
+ obj-$(CONFIG_CHARGER_PCF50633)        += pcf50633-charger.o
+ obj-$(CONFIG_BATTERY_JZ4740)  += jz4740-battery.o
++obj-$(CONFIG_CHARGER_GPIO)    += gpio-charger.o
+--- a/drivers/power/Kconfig    2010-02-03 13:16:32.000000000 +0100
++++ b/drivers/power/Kconfig    2010-02-01 14:58:24.000000000 +0100
+@@ -121,4 +121,11 @@
+         This driver can be build as a module. If so, the module will be
+         called jz4740-battery.
++config CHARGER_GPIO
++      tristate "GPIO charger"
++      depends on GPIOLIB
++      help
++        Say Y to include support for chargers indicating their status through
++        a GPIO pin.
++
+ endif # POWER_SUPPLY