toolchain/binutils: get rid of ARC leftovers
[openwrt/openwrt.git] / toolchain / binutils / Makefile
index f1e94b57577054afd65e08ed814601d7125ad2c0..0b7558e3584afb89b5b73e684910ab9a37a528e5 100644 (file)
@@ -15,16 +15,20 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 
 TAR_OPTIONS += --exclude='*.rej'
 
-ifeq ($(PKG_VERSION),2.32)
-  PKG_HASH:=0ab6c55dd86a92ed561972ba15b9b70a8b9f75557f896446c82e8b36e473ee04
+ifeq ($(PKG_VERSION),2.37)
+  PKG_HASH:=820d9724f020a3e69cb337893a0b63c2db161dadcb0e06fc11dc29eb1e84a32c
 endif
 
-ifeq ($(PKG_VERSION),2.34)
-  PKG_HASH:=f00b0e8803dc9bab1e2165bd568528135be734df3fabf8d0161828cd56028952
+ifeq ($(PKG_VERSION),2.38)
+  PKG_HASH:=e316477a914f567eccc34d5d29785b8b0f5a10208d36bbacedcc39048ecfe024
 endif
 
-ifeq ($(PKG_VERSION),2.35.2)
-  PKG_HASH:=dcd5b0416e7b0a9b24bed76cd8c6c132526805761863150a26d016415b8bdc7b
+ifeq ($(PKG_VERSION),2.39)
+  PKG_HASH:=645c25f563b8adc0a81dbd6a41cffbf4d37083a382e02d5d3df4f65c09516d00
+endif
+
+ifeq ($(PKG_VERSION),2.40)
+  PKG_HASH:=0f8a4c272d7f17f369ded10a4aca28b8e304828e95526da482b0ccc4dfc9d8e1
 endif
 
 HOST_BUILD_PARALLEL:=1
@@ -33,14 +37,24 @@ PATCH_DIR:=./patches/$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/toolchain-build.mk
 
+ifdef CONFIG_GCC_USE_GRAPHITE
+  GRAPHITE_CONFIGURE:= --with-isl=$(STAGING_DIR_HOST)
+else
+  GRAPHITE_CONFIGURE:= --without-isl --without-cloog
+endif
+
 HOST_CONFIGURE_ARGS = \
        --prefix=$(TOOLCHAIN_DIR) \
        --build=$(GNU_HOST_NAME) \
        --host=$(GNU_HOST_NAME) \
        --target=$(REAL_GNU_TARGET_NAME) \
        --with-sysroot=$(TOOLCHAIN_DIR) \
+       --with-system-zlib \
+       --without-zstd \
        --enable-deterministic-archives \
        --enable-plugins \
+       --enable-lto \
+       --disable-gprofng \
        --disable-multilib \
        --disable-werror \
        --disable-nls \
@@ -88,12 +102,6 @@ define Host/Install
        $(call FixupLibdir,$(TOOLCHAIN_DIR)/initial)
        $(RM) $(TOOLCHAIN_DIR)/initial/lib/libiberty.a
        $(CP) $(TOOLCHAIN_DIR)/bin/$(REAL_GNU_TARGET_NAME)-readelf $(HOST_BUILD_PREFIX)/bin/readelf
-       # ARC gcc requires extlib.
-       # If extlib is not available in "initial" folder
-       # initial gcc will fail to build libc.
-       if [ -d $(TOOLCHAIN_DIR)/extlib ]; then \
-               $(CP) -r $(TOOLCHAIN_DIR)/extlib $(TOOLCHAIN_DIR)/initial/; \
-       fi
 endef
 
 define Host/Clean