build: remove GCC7 support
[openwrt/openwrt.git] / toolchain / gcc / common.mk
index ec3ea8fff1d92ab9edde78df81073b280d3b303f..a1950028883676329765129fd9d6dc0faf5a8871 100644 (file)
@@ -28,20 +28,16 @@ GCC_DIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=@GNU/gcc/gcc-$(PKG_VERSION)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 
-ifeq ($(PKG_VERSION),5.5.0)
-  PKG_HASH:=530cea139d82fe542b358961130c69cfde8b3d14556370b65823d2f91f0ced87
-endif
-
-ifeq ($(PKG_VERSION),7.5.0)
-  PKG_HASH:=b81946e7f01f90528a1f7352ab08cc602b9ccc05d4e44da4bd501c5a189ee661
-endif
-
 ifeq ($(PKG_VERSION),8.4.0)
   PKG_HASH:=e30a6e52d10e1f27ed55104ad233c30bd1e99cfb5ff98ab022dc941edd1b2dd4
 endif
 
-ifeq ($(PKG_VERSION),9.3.0)
-  PKG_HASH:=71e197867611f6054aa1119b13a0c0abac12834765fe2d81f35ac57f84f742d1
+ifeq ($(PKG_VERSION),10.3.0)
+  PKG_HASH:=64f404c1a650f27fc33da242e1f2df54952e3963a49e06e73f6940f3223ac344
+endif
+
+ifeq ($(PKG_VERSION),11.2.0)
+  PKG_HASH:=d08edc536b54c372a1010ff6619dd274c0f1603aa49212ba20f7aa2cda36fa8b
 endif
 
 PATCH_DIR=../patches/$(GCC_VERSION)
@@ -117,7 +113,9 @@ GCC_CONFIGURE:= \
                --with-mpc=$(TOPDIR)/staging_dir/host \
                --disable-decimal-float \
                --with-diagnostics-color=auto-if-env \
-               --enable-__cxa_atexit
+               --enable-__cxa_atexit \
+               --disable-libstdcxx-dual-abi \
+               --with-default-libstdcxx-abi=new
 ifneq ($(CONFIG_mips)$(CONFIG_mipsel),)
   GCC_CONFIGURE += --with-mips-plt
 endif