gcc: gcc 4.9.x disable libsanitize
[openwrt/staging/wigyori.git] / toolchain / gcc / final / Makefile
index e8c32f629dc77af1eeaae99df135cd54ca407905..3fb5ccf83fe63466617c6045001284c0af354155 100644 (file)
@@ -4,6 +4,7 @@ include ../common.mk
 
 GCC_CONFIGURE += \
        --with-headers=$(TOOLCHAIN_DIR)/include \
+       --disable-libsanitizer \
        --enable-languages=$(TARGET_LANGUAGES) \
        --enable-shared \
        --enable-threads \
@@ -15,14 +16,6 @@ ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
        --with-libelf=$(TOPDIR)/staging_dir/host
 endif
 
-ifneq ($(CONFIG_TLS_SUPPORT),)
-  GCC_CONFIGURE += \
-       --enable-tls
-else
-  GCC_CONFIGURE += \
-       --disable-tls
-endif
-
 ifneq ($(CONFIG_SJLJ_EXCEPTIONS),)
   GCC_CONFIGURE += \
        --enable-sjlj-exceptions
@@ -77,6 +70,7 @@ define Host/Install
                done; \
        );
        $(if $(CONFIG_EXTRA_TARGET_ARCH),$(call SetupExtraArch))
+       $(RM) $(TOOLCHAIN_DIR)/lib/libiberty.a
        $(SCRIPT_DIR)/patch-specs.sh "$(TOOLCHAIN_DIR)"
 endef