toolchain: gdb: Update to version 10.1
[openwrt/openwrt.git] / toolchain / gdb / Makefile
index 0aaa5e0dcb7508bf7e55503d7c09ae13db129068..0b4af1164b614cb7ce2f0013fbbcd1eb8c2e84a6 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2009 OpenWrt.org
+#
+# Copyright (C) 2006-2020 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,35 +7,39 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=6.8
+PKG_VERSION:=10.1
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=c9da266b884fb8fa54df786dfaadbc7a
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gdb
+PKG_HASH:=f82f1eceeec14a3afa2de8d9b0d3c91d5a3820e23e0a01bbb70ef9f0276b62c0
+GDB_DIR:=$(PKG_NAME)-$(PKG_VERSION)
 
-include $(INCLUDE_DIR)/toolchain-build.mk
+HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(GDB_DIR)
 
-define Host/Configure
-       (cd $(HOST_BUILD_DIR); \
-               gdb_cv_func_sigsetjmp=yes \
-               CFLAGS="-O2" \
-               $(HOST_BUILD_DIR)/configure \
-               --prefix=$(TOOLCHAIN_DIR) \
-               --build=$(GNU_HOST_NAME) \
-               --host=$(GNU_HOST_NAME) \
-               --target=$(REAL_GNU_TARGET_NAME) \
-               --disable-werror \
-               $(DISABLE_NLS) \
-               --without-uiout \
-               --disable-tui --disable-gdbtk --without-x \
-               --without-included-gettext \
-               --enable-threads \
-       );
-endef
+HOST_BUILD_PARALLEL:=1
 
-define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR)
-endef
+include $(INCLUDE_DIR)/toolchain-build.mk
+
+HOST_CONFIGURE_VARS += \
+       gdb_cv_func_sigsetjmp=yes
+
+HOST_CONFIGURE_ARGS = \
+       --prefix=$(TOOLCHAIN_DIR) \
+       --build=$(GNU_HOST_NAME) \
+       --host=$(GNU_HOST_NAME) \
+       --target=$(REAL_GNU_TARGET_NAME) \
+       --disable-werror \
+       --without-uiout \
+       --enable-tui --disable-gdbtk --without-x \
+       --without-included-gettext \
+       --enable-threads \
+       --with-expat \
+       --without-python \
+       --disable-binutils \
+       --disable-ld \
+       --disable-gas \
+       --disable-sim
 
 define Host/Install
        mkdir -p $(TOOLCHAIN_DIR)/bin