gdb: update to 7.5-2012.09
[openwrt/staging/yousong.git] / toolchain / gdb / Makefile
index 995161adece4a3f297d0d77186bb802710ac4d57..89f73ef49e2834473f818313d3f4d0eb23625f11 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2009 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,11 +7,15 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
-PKG_VERSION:=7.2
+PKG_REV:=7.5-2012.09
+PKG_VERSION_MAJOR:=7.5
+PKG_VERSION:=linaro-$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=64260e6c56979ee750a01055f16091a5
-PKG_SOURCE_URL:=@GNU/gdb
+PKG_MD5SUM:=758c2da97c27f7b50ca48cb803eaa9aa
+PKG_SOURCE_URL:=http://launchpad.net/gdb-linaro/$(PKG_VERSION_MAJOR)/$(PKG_REV)/+download/
+
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/toolchain-build.mk
 
@@ -33,10 +37,6 @@ define Host/Configure
        );
 endef
 
-define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR)
-endef
-
 define Host/Install
        mkdir -p $(TOOLCHAIN_DIR)/bin
        $(INSTALL_BIN) $(HOST_BUILD_DIR)/gdb/gdb $(TOOLCHAIN_DIR)/bin/$(TARGET_CROSS)gdb