toolchain: add mold as additional linker
[openwrt/staging/mans0n.git] / toolchain / mold / Makefile
diff --git a/toolchain/mold/Makefile b/toolchain/mold/Makefile
new file mode 100644 (file)
index 0000000..a2acba8
--- /dev/null
@@ -0,0 +1,22 @@
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/toolchain-build.mk
+
+define Host/Configure
+endef
+
+define Host/Compile
+endef
+
+define Host/Install
+       $(INSTALL_DIR) $(TOOLCHAIN_DIR)/bin
+       $(INSTALL_BIN) $(STAGING_DIR_HOST)/bin/mold $(TOOLCHAIN_DIR)/bin/$(REAL_GNU_TARGET_NAME)-ld.mold
+endef
+
+define Host/Clean
+endef
+
+$(eval $(call HostBuild))