toolchain/uClibc: Disable mips16 for uClibc for now
[openwrt/staging/chunkeey.git] / toolchain / uClibc / common.mk
index f32ed9872924502f46b9683e585a6171fd548d56..e84c02a1623a7e9b138ffd80b58dddd5969e2275 100644 (file)
@@ -44,6 +44,8 @@ GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n \
                $(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD), \
                        $(if $(CONFIG_HAS_SPE_FPU),$(if $(wildcard $(CONFIG_DIR)/$(ARCH).e500),.e500))))
 
+TARGET_CFLAGS := $(filter-out -mips16,$(TARGET_CFLAGS))
+
 CPU_CFLAGS = \
        -funsigned-char -fno-builtin -fno-asm \
        --std=gnu99 -ffunction-sections -fdata-sections \