uclibc: add some libpthread fixes
[openwrt/openwrt.git] / toolchain / uClibc / patches / 190-install_tls.patch
diff --git a/toolchain/uClibc/patches/190-install_tls.patch b/toolchain/uClibc/patches/190-install_tls.patch
new file mode 100644 (file)
index 0000000..74d4032
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/libpthread/linuxthreads/Makefile.in
++++ b/libpthread/linuxthreads/Makefile.in
+@@ -128,7 +128,9 @@ linuxthreads_headers:
+       $(Q)$(LN) -sf ../$(PTDIR)/sysdeps/pthread/pthread.h $(top_builddir)include/
+       $(Q)$(LN) -sf ../$(PTDIR)/semaphore.h $(top_builddir)include/
+       $(Q)$(INSTALL) -d $(top_builddir)include/bits
++      $(Q)$(INSTALL) -d $(top_builddir)include/sys
+       $(Q)$(LN) -sf ../../$(PTDIR)/sysdeps/pthread/bits/pthreadtypes.h $(top_builddir)include/bits/
++      $(Q)$(LN) -sf ../../$(PTDIR)/sysdeps/$(TARGET_ARCH)/tls.h $(top_builddir)include/sys/
+ linuxthreads_headers_clean:
+       $(RM) $(top_builddir)include/pthread.h $(top_builddir)include/semaphore.h \