tools/expat: build with autotools again
[openwrt/openwrt.git] / tools / expat / Makefile
index dfd5f286cd738f29a4eca64102a484ec985597e4..975219efd86c1e3bcfc3662ea0893935b3bc3f72 100644 (file)
@@ -8,18 +8,26 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=expat
-PKG_VERSION:=2.1.0
+PKG_CPE_ID:=cpe:/a:libexpat:expat
+PKG_VERSION:=2.4.8
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_MD5SUM:=dd7dab7a5fea97d2a6a43f511449b7cd
-PKG_SOURCE_URL:=@SF/expat
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_HASH:=a247a7f6bbb21cf2ca81ea4cbb916bfb9717ca523631675f99b3d4a5678dcd16
+PKG_SOURCE_URL:=https://github.com/libexpat/libexpat/releases/download/R_$(subst .,_,$(PKG_VERSION))
 
 HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Host/Install
-       $(MAKE) -C $(HOST_BUILD_DIR) install
+HOSTCC := $(HOSTCC_NOCACHE)
+
+HOST_CONFIGURE_ARGS += \
+       --disable-shared \
+       --without-docbook \
+       --with-pic
+
+define Host/Uninstall
+       -$(call Host/Compile/Default,uninstall)
 endef
 
 $(eval $(call HostBuild))