tools/findutils: fix build on macos
[openwrt/staging/dedeckeh.git] / tools / findutils / Makefile
index c40fa6efc18c1e9be1b51c38ca8705ddd431be79..37cd897355c3c13e799f19437bb1cd01af6ba465 100644 (file)
@@ -18,6 +18,10 @@ HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+ifeq ($(HOST_OS),Darwin)
+       HOST_CFLAGS +=-D__nonnull\\(params\\)=
+endif
+
 HOST_CONFIGURE_ARGS += \
        --enable-threads=pth \
        --disable-rpath \