tools/flex: override SUBDIRS variable with Makefile
[openwrt/staging/stintel.git] / tools / flex / Makefile
index da037ae72d84b52181e28c8e46495ad922b9f4d2..86ba5a4415d3a82aaf5e9897736b465cc7e30c42 100644 (file)
@@ -21,13 +21,17 @@ include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CONFIGURE_ARGS += --disable-shared
 
+define Host/Compile
+       $(call Host/Compile/Default,SUBDIRS='src tools')
+endef
+
 define Host/Install
-       $(call Host/Install/Default)
+       $(call Host/Compile/Default,install SUBDIRS='src tools')
        $(LN) flex $(STAGING_DIR_HOST)/bin/lex
 endef
 
 define Host/Uninstall
-       -$(call Host/Compile/Default,uninstall)
+       -$(call Host/Compile/Default,uninstall SUBDIRS='src tools')
 endef
 
 define Host/Clean