flex: fix build error due to undefined library symbols
[openwrt/openwrt.git] / tools / flex / patches / 100-remove_no_undefined.patch
diff --git a/tools/flex/patches/100-remove_no_undefined.patch b/tools/flex/patches/100-remove_no_undefined.patch
new file mode 100644 (file)
index 0000000..4e8aca1
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -73,13 +73,13 @@ libfl_la_SOURCES = \
+       libmain.c \
+       libyywrap.c
+-libfl_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
++libfl_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
+ libfl_pic_la_SOURCES = \
+       libmain.c \
+       libyywrap.c
+-libfl_pic_la_LDFLAGS = -no-undefined -version-info @SHARED_VERSION_INFO@
++libfl_pic_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
+ noinst_HEADERS = \
+       flexdef.h \