fix graphite options with gcc-4.5, add libelf for LTO, fix mbsd_multi patch, patch...
[openwrt/staging/lynxis.git] / tools / libelf / Makefile
diff --git a/tools/libelf/Makefile b/tools/libelf/Makefile
new file mode 100644 (file)
index 0000000..f38d70d
--- /dev/null
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libelf
+PKG_VERSION:=0.8.13
+PKG_MD5SUM:=4136d7b4c04df68b686570afa26988ac
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://www.mr511.de/software/
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOST_CONFIGURE_ARGS += \
+       --disable-shared \
+       --enable-elf64
+
+define Host/Configure
+        (cd $(HOST_BUILD_DIR)/$(3); \
+                $(HOST_CONFIGURE_CMD) \
+                $(HOST_CONFIGURE_ARGS); \
+        )
+endef
+
+
+define Host/Compile
+       $(MAKE) -C $(HOST_BUILD_DIR)/lib/ libelf.a
+endef
+
+define Host/Install
+       $(INSTALL_DIR) $(STAGING_DIR_HOST)/{lib,include/libelf}
+       $(CP) $(HOST_BUILD_DIR)/lib/{elf_repl.h,gelf.h,libelf.h,nlist.h,sys_elf.h} \
+                                               $(STAGING_DIR_HOST)/include/libelf/
+       $(CP) $(HOST_BUILD_DIR)/lib/libelf.a $(STAGING_DIR_HOST)/lib/
+endef
+
+define Host/Clean
+       rm -rf $(STAGING_DIR_HOST)/include/libelf
+       rm -f $(STAGING_DIR_HOST)/lib/libelf.a
+       $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))