tools: Fix mkimage build on FreeBSD 10.1
[openwrt/staging/yousong.git] / tools / mkimage / patches / 100-freebsd-compat.patch
diff --git a/tools/mkimage/patches/100-freebsd-compat.patch b/tools/mkimage/patches/100-freebsd-compat.patch
new file mode 100644 (file)
index 0000000..e014af5
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/Makefile
++++ b/Makefile
+@@ -584,7 +584,10 @@ UBOOTINCLUDE    := \
+               -I$(srctree)/arch/$(ARCH)/include \
+               -include $(srctree)/include/linux/kconfig.h
+-NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
++ifneq ($(shell uname),FreeBSD)
++  NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
++endif
++
+ CHECKFLAGS     += $(NOSTDINC_FLAGS)
+ # FIX ME