tools: create a new tool for more efficient jffs2 padding
[openwrt/staging/jow.git] / tools / padjffs2 / Makefile
diff --git a/tools/padjffs2/Makefile b/tools/padjffs2/Makefile
new file mode 100644 (file)
index 0000000..a057ddd
--- /dev/null
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=padjffs2
+PKG_VERSION:=1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Prepare
+       mkdir -p $(HOST_BUILD_DIR)
+       $(CP) ./src/* $(HOST_BUILD_DIR)/
+       find $(HOST_BUILD_DIR) -name .svn | $(XARGS) rm -rf
+endef
+
+define Host/Configure
+endef
+
+define Host/Compile
+       $(MAKE) CC="$(HOSTCC)" -C $(HOST_BUILD_DIR)
+endef
+
+define Host/Install
+       $(CP) $(HOST_BUILD_DIR)/padjffs2 $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+       rm -f $(STAGING_DIR_HOST)/bin/padjffs2
+endef
+
+$(eval $(call HostBuild))