tools/quilt: fix openSUSE/patch-2.6.1.81 issue (closes #7635)
[openwrt/staging/chunkeey.git] / tools / quilt / patches / 100-patch_2.6.1_version.patch
diff --git a/tools/quilt/patches/100-patch_2.6.1_version.patch b/tools/quilt/patches/100-patch_2.6.1_version.patch
new file mode 100644 (file)
index 0000000..84f2753
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -274,7 +274,7 @@ fi
+ AC_MSG_CHECKING([the version of $PATCH])
+ if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
+   set -- `$PATCH --version 2> /dev/null`
+-  patch_version=$2
++  test $2 == "patch" && patch_version=$3 || patch_version=$2
+   AC_MSG_RESULT($patch_version)
+   saved_IFS=$IFS; IFS='.'
+   set -- $patch_version