[tools] sed: disable further SELinux features
[openwrt/svn-archive/archive.git] / tools / sed / Makefile
index 9ccfc7b9d3bceaede0194c633ac2d1d350960e09..210feceb715f60d2b4b464ea39332dcc4ab06d8c 100644 (file)
@@ -17,8 +17,17 @@ export SED:=
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_CONFIGURE_ARGS += \
+       --disable-acl \
+       --disable-nls \
+
+HOST_CONFIGURE_VARS += \
+       ac_cv_search_setfilecon=no \
+       ac_cv_header_selinux_context_h=no \
+       ac_cv_header_selinux_selinux_h=no \
+
 define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)"
+       $(MAKE) -C $(HOST_BUILD_DIR) SHELL="$(BASH)" LDFLAGS="-static"
 endef
 
 define Host/Install