tools/squashfs4: add new tool for squashfs4 images
[openwrt/staging/dedeckeh.git] / tools / squashfs4 / Makefile
diff --git a/tools/squashfs4/Makefile b/tools/squashfs4/Makefile
new file mode 100644 (file)
index 0000000..9d4f6ba
--- /dev/null
@@ -0,0 +1,41 @@
+#
+# Copyright (C) 2006-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=squashfs4
+PKG_CPE_ID:=cpe:/a:phillip_lougher:squashfs
+PKG_VERSION:=4.5.1
+PKG_RELEASE=1
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=https://github.com/plougher/squashfs-tools
+PKG_SOURCE_DATE:=2022-03-17
+PKG_SOURCE_VERSION:=afdd63fc386919b4aa40d573b0a6069414d14317
+PKG_MIRROR_HASH:=caedb66cf6dcbdcee0d1525923e203d003ef15f34a13a328686794666f16171f
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+       +$(HOST_MAKE_VARS) \
+       $(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
+               XZ_SUPPORT=1 \
+               LZMA_XZ_SUPPORT=1 \
+               EXTRA_CFLAGS="-I$(STAGING_DIR_HOST)/include" \
+               mksquashfs unsquashfs
+endef
+
+define Host/Install
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/squashfs-tools/mksquashfs $(STAGING_DIR_HOST)/bin/mksquashfs4
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/squashfs-tools/unsquashfs $(STAGING_DIR_HOST)/bin/unsquashfs4
+endef
+
+define Host/Clean
+       rm -f $(STAGING_DIR_HOST)/bin/mksquashfs4
+       rm -f $(STAGING_DIR_HOST)/bin/unsquashfs4
+endef
+
+$(eval $(call HostBuild))