build: add the + token to any commands that can pass through the jobserver, fixes...
[openwrt/staging/mkresin.git] / tools / xz / Makefile
index 660f6e899cc38d5d102a057873a8791b4d6fb368..9999006d4884b82b5c644699238d5a33caac1a33 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,16 +7,21 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=xz
-PKG_VERSION:=5.0.0
+PKG_VERSION:=5.0.4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://tukaani.org/xz
-PKG_MD5SUM:=0652c09fdbb93ae2ce78c1368ffda612
+PKG_MD5SUM:=741cd3a5f64b23b7bac56ec5b2258715
+
+HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
+
 define Host/Install
-       $(MAKE) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"
+       +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat" \
+               AM_LDFLAGS="$(if $(HOST_STATIC_LINKING),-all-static)"
 endef
 
 $(eval $(call HostBuild))