utils/bash: Update to 5.0
[feed/packages.git] / utils / bash / Makefile
index 039e70cef4a985ec011ec16cec736b1b3f64d048..571290e8996a32028a94fb41e01f48fe272dc602 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bash
-PKG_VERSION:=4.4.18
-PKG_RELEASE:=2
+PKG_VERSION:=5.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@GNU/bash
-PKG_HASH:=604d9eec5e4ed5fd2180ee44dd756ddca92e0b6aa4217bbab2b6227380317f23
+PKG_HASH:=b4a80f2ac66170b2913efbfb9f2594f1f76c7b1afd11f799e22035d63077fb4d
 
 PKG_LICENSE:=GPL-3.0+
 PKG_LICENSE_FILES:=COPYING
@@ -55,7 +55,7 @@ endef
 # bash_cv_sys_named_pipes: Required for process substituion
 CONFIGURE_VARS += \
        ac_cv_rl_prefix="$(STAGING_DIR)/usr" \
-       ac_cv_rl_version="7.0" \
+       ac_cv_rl_version="8.0" \
        bash_cv_getcwd_malloc=yes \
        bash_cv_job_control_missing=present \
        bash_cv_dev_fd=whacky \
@@ -72,6 +72,9 @@ CONFIGURE_ARGS+= \
        --without-bash-malloc \
        --bindir=/bin \
        --disable-rpath \
+       --enable-direxpand-default \
+       --enable-job-control \
+       --enable-readline
 
 define Package/bash/postinst
 #!/bin/sh
@@ -87,5 +90,4 @@ define Package/bash/install
        $(LN) bash $(1)/bin/rbash
 endef
 
-
 $(eval $(call BuildPackage,bash))