bluez: Update to version 5.51
[feed/packages.git] / utils / bluez / patches / 201-readline.patch
index 01c7e5e9ea2bbde855a49ae85575446764548021..228c0e400abaf55f388fe2d88d37ddcc5301e169 100644 (file)
@@ -1,43 +1,43 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -2547,7 +2547,7 @@ unit_tests = $(am__append_52) unit/test-
+--- bluez-5.51.orig/Makefile.in
++++ bluez-5.51/Makefile.in
+@@ -3125,7 +3125,7 @@ unit_tests = $(am__append_54) unit/test-
  @CLIENT_TRUE@                                 client/gatt.h client/gatt.c
  
  @CLIENT_TRUE@client_bluetoothctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
--@CLIENT_TRUE@                         @GLIB_LIBS@ @DBUS_LIBS@ -lreadline
-+@CLIENT_TRUE@                         @GLIB_LIBS@ @DBUS_LIBS@ -lreadline -lncurses
+-@CLIENT_TRUE@                         $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
++@CLIENT_TRUE@                         $(GLIB_LIBS) $(DBUS_LIBS) -lreadline -lncurses
  
- @MESH_TRUE@mesh_meshctl_SOURCES = mesh/main.c \
- @MESH_TRUE@                           mesh/mesh-net.h \
-@@ -2566,7 +2566,7 @@ unit_tests = $(am__append_52) unit/test-
+ @ZSH_COMPLETIONS_TRUE@zshcompletiondir = $(ZSH_COMPLETIONDIR)
+ @ZSH_COMPLETIONS_TRUE@dist_zshcompletion_DATA = completion/zsh/_bluetoothctl
+@@ -3358,7 +3358,7 @@ unit_tests = $(am__append_54) unit/test-
  
- @MESH_TRUE@mesh_meshctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
- @MESH_TRUE@                           lib/libbluetooth-internal.la \
--@MESH_TRUE@                           @GLIB_LIBS@ @DBUS_LIBS@ -ljson-c -lreadline
-+@MESH_TRUE@                           @GLIB_LIBS@ @DBUS_LIBS@ -ljson-c -lreadline -lncurses
+ @MESH_TRUE@@TOOLS_TRUE@tools_meshctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
+ @MESH_TRUE@@TOOLS_TRUE@                               lib/libbluetooth-internal.la \
+-@MESH_TRUE@@TOOLS_TRUE@                               $(GLIB_LIBS) $(DBUS_LIBS) -ljson-c -lreadline
++@MESH_TRUE@@TOOLS_TRUE@                               $(GLIB_LIBS) $(DBUS_LIBS) -ljson-c -lreadline -lncurses
  
- @MONITOR_TRUE@monitor_btmon_SOURCES = monitor/main.c monitor/bt.h \
- @MONITOR_TRUE@                                monitor/display.h monitor/display.c \
-@@ -2827,7 +2827,7 @@ unit_tests = $(am__append_52) unit/test-
+ @DEPRECATED_TRUE@@TOOLS_TRUE@tools_hciattach_SOURCES = tools/hciattach.c tools/hciattach.h \
+ @DEPRECATED_TRUE@@TOOLS_TRUE@                                         tools/hciattach_st.c \
+@@ -3411,7 +3411,7 @@ unit_tests = $(am__append_54) unit/test-
  @READLINE_TRUE@                                               tools/obex-client-tool.c
  
  @READLINE_TRUE@tools_obex_client_tool_LDADD = lib/libbluetooth-internal.la \
--@READLINE_TRUE@                                               @GLIB_LIBS@ -lreadline
-+@READLINE_TRUE@                                               @GLIB_LIBS@ -lreadline -lncurses
+-@READLINE_TRUE@                                               $(GLIB_LIBS) -lreadline
++@READLINE_TRUE@                                               $(GLIB_LIBS) -lreadline -lncurses
  
  @READLINE_TRUE@tools_obex_server_tool_SOURCES = $(gobex_sources) $(btio_sources) \
  @READLINE_TRUE@                                               tools/obex-server-tool.c
-@@ -2836,15 +2836,15 @@ unit_tests = $(am__append_52) unit/test-
+@@ -3420,15 +3420,15 @@ unit_tests = $(am__append_54) unit/test-
  @READLINE_TRUE@tools_bluetooth_player_SOURCES = tools/bluetooth-player.c
  @READLINE_TRUE@tools_bluetooth_player_LDADD = gdbus/libgdbus-internal.la \
  @READLINE_TRUE@                               src/libshared-glib.la \
--@READLINE_TRUE@                               @GLIB_LIBS@ @DBUS_LIBS@ -lreadline
-+@READLINE_TRUE@                               @GLIB_LIBS@ @DBUS_LIBS@ -lreadline -lncurses
+-@READLINE_TRUE@                               $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
++@READLINE_TRUE@                               $(GLIB_LIBS) $(DBUS_LIBS) -lreadline -lncurses
  
  @READLINE_TRUE@tools_obexctl_SOURCES = tools/obexctl.c
  @READLINE_TRUE@tools_obexctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
--@READLINE_TRUE@                               @GLIB_LIBS@ @DBUS_LIBS@ -lreadline
-+@READLINE_TRUE@                               @GLIB_LIBS@ @DBUS_LIBS@ -lreadline -lncurses
+-@READLINE_TRUE@                               $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
++@READLINE_TRUE@                               $(GLIB_LIBS) $(DBUS_LIBS) -lreadline -lncurses
  
  @READLINE_TRUE@tools_btmgmt_SOURCES = tools/btmgmt.c src/uuid-helper.c client/display.c
  @READLINE_TRUE@tools_btmgmt_LDADD = lib/libbluetooth-internal.la src/libshared-mainloop.la \
  
  @DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_SOURCES = attrib/gatttool.c attrib/att.c attrib/gatt.c \
  @DEPRECATED_TRUE@@READLINE_TRUE@                              attrib/gattrib.c btio/btio.c \
-@@ -2853,7 +2853,7 @@ unit_tests = $(am__append_52) unit/test-
+@@ -3437,7 +3437,7 @@ unit_tests = $(am__append_54) unit/test-
  @DEPRECATED_TRUE@@READLINE_TRUE@                              client/display.h
  
  @DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_LDADD = lib/libbluetooth-internal.la \
--@DEPRECATED_TRUE@@READLINE_TRUE@                      src/libshared-glib.la @GLIB_LIBS@ -lreadline
-+@DEPRECATED_TRUE@@READLINE_TRUE@                      src/libshared-glib.la @GLIB_LIBS@ -lreadline -lncurses
+-@DEPRECATED_TRUE@@READLINE_TRUE@                      src/libshared-glib.la $(GLIB_LIBS) -lreadline
++@DEPRECATED_TRUE@@READLINE_TRUE@                      src/libshared-glib.la $(GLIB_LIBS) -lreadline -lncurses
  
  @CUPS_TRUE@cupsdir = $(libdir)/cups/backend
  @CUPS_TRUE@profiles_cups_bluetooth_SOURCES = profiles/cups/main.c \