bluez: update to 5.72
[feed/packages.git] / utils / bluez / patches / 201-readline.patch
index e58b504b30a98c420f1b93f186ae0daa2156af91..7f6051abc468e1c35c2f6cb0053906e4f4d1804f 100644 (file)
@@ -1,75 +1,74 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -3598,7 +3598,7 @@ unit_tests = $(am__append_62) unit/test-
- @CLIENT_TRUE@                                 client/player.h client/player.c
+--- a/Makefile.tools
++++ b/Makefile.tools
+@@ -16,7 +16,7 @@ client_bluetoothctl_SOURCES = client/mai
+                                       client/mgmt.h client/mgmt.c
+ client_bluetoothctl_LDADD = lib/libbluetooth-internal.la \
+                       gdbus/libgdbus-internal.la src/libshared-glib.la \
+-                      $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
++                      $(GLIB_LIBS) $(DBUS_LIBS) -lreadline -lncurses
+ endif
  
- @CLIENT_TRUE@client_bluetoothctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
--@CLIENT_TRUE@                         $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
-+@CLIENT_TRUE@                         $(GLIB_LIBS) $(DBUS_LIBS) -lreadline -lncurses
+ if ZSH_COMPLETIONS
+@@ -382,7 +382,7 @@ tools_meshctl_SOURCES = tools/meshctl.c
+                               tools/mesh-gatt/onoff-model.c
+ tools_meshctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
+                               lib/libbluetooth-internal.la \
+-                              $(GLIB_LIBS) $(DBUS_LIBS) -ljson-c -lreadline
++                              $(GLIB_LIBS) $(DBUS_LIBS) -ljson-c -lreadline -lncurses
  
- @ZSH_COMPLETIONS_TRUE@zshcompletiondir = $(ZSH_COMPLETIONDIR)
- @ZSH_COMPLETIONS_TRUE@dist_zshcompletion_DATA = completion/zsh/_bluetoothctl
-@@ -3877,7 +3877,7 @@ unit_tests = $(am__append_62) unit/test-
+ EXTRA_DIST += tools/mesh-gatt/local_node.json tools/mesh-gatt/prov_db.json
+ endif
+@@ -401,7 +401,7 @@ tools_mesh_cfgclient_SOURCES = tools/mes
+                               mesh/crypto.h mesh/crypto.c
  
- @DEPRECATED_TRUE@@MESH_TRUE@@TOOLS_TRUE@tools_meshctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
- @DEPRECATED_TRUE@@MESH_TRUE@@TOOLS_TRUE@                              lib/libbluetooth-internal.la \
--@DEPRECATED_TRUE@@MESH_TRUE@@TOOLS_TRUE@                              $(GLIB_LIBS) $(DBUS_LIBS) -ljson-c -lreadline
-+@DEPRECATED_TRUE@@MESH_TRUE@@TOOLS_TRUE@                              $(GLIB_LIBS) $(DBUS_LIBS) -ljson-c -lreadline -lncurses
+ tools_mesh_cfgclient_LDADD = lib/libbluetooth-internal.la src/libshared-ell.la \
+-                                              $(ell_ldadd) -ljson-c -lreadline
++                                              $(ell_ldadd) -ljson-c -lreadline -lncurses
  
- @MESH_TRUE@@TOOLS_TRUE@tools_mesh_cfgclient_SOURCES = tools/mesh-cfgclient.c \
- @MESH_TRUE@@TOOLS_TRUE@                               tools/mesh/model.h tools/mesh/config-model.h \
-@@ -3891,7 +3891,7 @@ unit_tests = $(am__append_62) unit/test-
- @MESH_TRUE@@TOOLS_TRUE@                               mesh/crypto.h mesh/crypto.c
+ bin_PROGRAMS +=  tools/mesh-cfgtest
  
- @MESH_TRUE@@TOOLS_TRUE@tools_mesh_cfgclient_LDADD = lib/libbluetooth-internal.la src/libshared-ell.la \
--@MESH_TRUE@@TOOLS_TRUE@                                               $(ell_ldadd) -ljson-c -lreadline
-+@MESH_TRUE@@TOOLS_TRUE@                                               $(ell_ldadd) -ljson-c -lreadline -lncurses
+@@ -507,7 +507,7 @@ noinst_PROGRAMS += tools/btmgmt tools/ob
+ tools_obex_client_tool_SOURCES = $(gobex_sources) $(btio_sources) \
+                                               tools/obex-client-tool.c
+ tools_obex_client_tool_LDADD = lib/libbluetooth-internal.la \
+-                             src/libshared-glib.la $(GLIB_LIBS) -lreadline
++                             src/libshared-glib.la $(GLIB_LIBS) -lreadline -lncurses
  
- @MESH_TRUE@@TOOLS_TRUE@tools_mesh_cfgtest_SOURCES = tools/mesh-cfgtest.c
- @MESH_TRUE@@TOOLS_TRUE@tools_mesh_cfgtest_LDADD = lib/libbluetooth-internal.la src/libshared-ell.la \
-@@ -3948,7 +3948,7 @@ unit_tests = $(am__append_62) unit/test-
- @READLINE_TRUE@                                               tools/obex-client-tool.c
+ tools_obex_server_tool_SOURCES = $(gobex_sources) $(btio_sources) \
+                                               tools/obex-server-tool.c
+@@ -518,16 +518,16 @@ tools_bluetooth_player_SOURCES = tools/b
+                               client/player.c
+ tools_bluetooth_player_LDADD = gdbus/libgdbus-internal.la \
+                               src/libshared-glib.la \
+-                              $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
++                              $(GLIB_LIBS) $(DBUS_LIBS) -lreadline -lncurses
  
- @READLINE_TRUE@tools_obex_client_tool_LDADD = lib/libbluetooth-internal.la \
--@READLINE_TRUE@                              src/libshared-glib.la $(GLIB_LIBS) -lreadline
-+@READLINE_TRUE@                              src/libshared-glib.la $(GLIB_LIBS) -lreadline -lncurses
+ tools_obexctl_SOURCES = tools/obexctl.c
+ tools_obexctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
+-                      $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
++                      $(GLIB_LIBS) $(DBUS_LIBS) -lreadline -lncurses
  
- @READLINE_TRUE@tools_obex_server_tool_SOURCES = $(gobex_sources) $(btio_sources) \
- @READLINE_TRUE@                                               tools/obex-server-tool.c
-@@ -3959,15 +3959,15 @@ unit_tests = $(am__append_62) unit/test-
- @READLINE_TRUE@tools_bluetooth_player_SOURCES = tools/bluetooth-player.c client/player.c
- @READLINE_TRUE@tools_bluetooth_player_LDADD = gdbus/libgdbus-internal.la \
- @READLINE_TRUE@                               src/libshared-glib.la \
--@READLINE_TRUE@                               $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
-+@READLINE_TRUE@                               $(GLIB_LIBS) $(DBUS_LIBS) -lreadline -lncurses
+ tools_btmgmt_SOURCES = tools/btmgmt.c src/uuid-helper.c client/display.c \
+                       client/mgmt.c
+ tools_btmgmt_LDADD = lib/libbluetooth-internal.la src/libshared-mainloop.la \
+-                              -lreadline
++                              -lreadline -lncurses
+ if DEPRECATED
+ noinst_PROGRAMS += attrib/gatttool
  
- @READLINE_TRUE@tools_obexctl_SOURCES = tools/obexctl.c
- @READLINE_TRUE@tools_obexctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
--@READLINE_TRUE@                       $(GLIB_LIBS) $(DBUS_LIBS) -lreadline
-+@READLINE_TRUE@                       $(GLIB_LIBS) $(DBUS_LIBS) -lreadline -lncurses
+@@ -537,7 +537,7 @@ attrib_gatttool_SOURCES = attrib/gatttoo
+                               attrib/utils.c src/log.c client/display.c \
+                               client/display.h
+ attrib_gatttool_LDADD = lib/libbluetooth-internal.la \
+-                      src/libshared-glib.la $(GLIB_LIBS) -lreadline
++                      src/libshared-glib.la $(GLIB_LIBS) -lreadline -lncurses
  
- @READLINE_TRUE@tools_btmgmt_SOURCES = tools/btmgmt.c src/uuid-helper.c client/display.c
- @READLINE_TRUE@tools_btmgmt_LDADD = lib/libbluetooth-internal.la src/libshared-mainloop.la \
--@READLINE_TRUE@                               -lreadline
-+@READLINE_TRUE@                               -lreadline -lncurses
+ endif
+ endif
+@@ -583,5 +583,5 @@ tools/btpclient.$(OBJEXT): src/libshared
  
- @DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_SOURCES = attrib/gatttool.c attrib/att.c attrib/gatt.c \
- @DEPRECATED_TRUE@@READLINE_TRUE@                              attrib/gattrib.c btio/btio.c \
-@@ -3976,7 +3976,7 @@ unit_tests = $(am__append_62) unit/test-
- @DEPRECATED_TRUE@@READLINE_TRUE@                              client/display.h
- @DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_LDADD = lib/libbluetooth-internal.la \
--@DEPRECATED_TRUE@@READLINE_TRUE@                      src/libshared-glib.la $(GLIB_LIBS) -lreadline
-+@DEPRECATED_TRUE@@READLINE_TRUE@                      src/libshared-glib.la $(GLIB_LIBS) -lreadline -lncurses
- @CUPS_TRUE@cupsdir = $(libdir)/cups/backend
- @CUPS_TRUE@profiles_cups_bluetooth_SOURCES = profiles/cups/main.c \
-@@ -3996,7 +3996,7 @@ unit_tests = $(am__append_62) unit/test-
- @BTPCLIENT_TRUE@tools_btpclient_DEPENDENCIES = lib/libbluetooth-internal.la $(ell_dependencies)
- @BTPCLIENT_TRUE@tools_btpclientctl_SOURCES = tools/btpclientctl.c client/display.c
- @BTPCLIENT_TRUE@tools_btpclientctl_LDADD = src/libshared-mainloop.la src/libshared-glib.la \
--@BTPCLIENT_TRUE@                              lib/libbluetooth-internal.la -lreadline
-+@BTPCLIENT_TRUE@                              lib/libbluetooth-internal.la -lreadline -lncurses
- # SPDX-License-Identifier: GPL-2.0
+ tools_btpclientctl_SOURCES = tools/btpclientctl.c client/display.c
+ tools_btpclientctl_LDADD = src/libshared-mainloop.la src/libshared-glib.la \
+-                              lib/libbluetooth-internal.la -lreadline
++                              lib/libbluetooth-internal.la -lreadline -lncurses
+ endif