cryptsetup: fix compilation with musl 1.2.4
[feed/packages.git] / utils / cryptsetup / Makefile
index f9a76e6c4134cf97c2df842dcd8836b7e93a5e66..575fb34a04bd84a6c41deb05846fcce042153961 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cryptsetup
 PKG_VERSION:=2.6.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@KERNEL/linux/utils/cryptsetup/v2.6
@@ -75,6 +75,7 @@ CONFIGURE_VARS += \
        LIBSSH_CFLAGS="-I$(STAGING_DIR)/usr/include" \
        LIBSSH_LIBS="-L$(STAGING_DIR)/usr/lib -lssh"
 
+TARGET_CFLAGS += -D_LARGEFILE64_SOURCE
 TARGET_LDFLAGS += -Wl,--gc-sections $(if $(INTL_FULL),-lintl)
 
 define Build/InstallDev