klish: fixup sigignore support
[feed/packages.git] / utils / klish / Makefile
index e510291b04616c58f48b0e9d26d3ab869e737547..17e813375a3d0927d84add327c86dabf714a5b33 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=klish
 PKG_VERSION:=2.2.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://libcode.org/attachments/download/77/
@@ -54,6 +54,8 @@ endef
 
 CONFIGURE_ARGS += --with-libxml2
 
+TARGET_CFLAGS += -D_GNU_SOURCE
+
 define Package/klish/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/clish $(1)/usr/bin/