mariadb: fix compilation when selinux is present
[feed/packages.git] / utils / mariadb / patches / 200-no-selinux.patch
diff --git a/utils/mariadb/patches/200-no-selinux.patch b/utils/mariadb/patches/200-no-selinux.patch
new file mode 100644 (file)
index 0000000..d7ed569
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/support-files/CMakeLists.txt
++++ b/support-files/CMakeLists.txt
+@@ -61,7 +61,7 @@ IF(UNIX)
+     INSTALL(FILES magic DESTINATION ${inst_location} COMPONENT SupportFiles)
+     INSTALL(DIRECTORY policy DESTINATION ${inst_location} COMPONENT SupportFiles)
+     FIND_PROGRAM(CHECKMODULE checkmodule)
+-    FIND_PROGRAM(SEMODULE_PACKAGE semodule_package)
++#    FIND_PROGRAM(SEMODULE_PACKAGE semodule_package)
+     MARK_AS_ADVANCED(CHECKMODULE SEMODULE_PACKAGE)
+     # Build pp files in policy/selinux