unzip: fix cross-compilation and skip target checks
[feed/packages.git] / utils / unzip / Makefile
index 1628d0406f7c0d7e259698065a4ef9bbeb38e7c9..441b4835ef452c7a76dffbb4daf8b9d6ea0d9ea5 100644 (file)
@@ -43,12 +43,15 @@ endef
 define Build/Configure
 endef
 
+TARGET_CFLAGS += -DNO_LCHMOD -DLARGE_FILE_SUPPORT
+
 define Build/Compile
-       $(MAKE) -C $(PKG_BUILD_DIR) -f unix/Makefile generic \
+       $(MAKE) -C $(PKG_BUILD_DIR) -f unix/Makefile unzips \
                $(TARGET_CONFIGURE_OPTS) \
                prefix="$(PKG_INSTALL_DIR)/usr" \
                CFLAGS="$(TARGET_CFLAGS)" \
                CF="$(TARGET_CFLAGS) -O $(TARGET_CPPFLAGS) -I. -DUNIX" \
+               CC="$(TARGET_CC)" \
                LD="$(TARGET_CC) $(TARGET_LDFLAGS)" \
                install
 endef